Go Back   Serif Software Forums > Design and Publishing > PagePlus

Notices

PagePlus Questions about using PagePlus for desktop publishing

 
 
Thread Tools Display Modes
Old 7th April 2006, 11:00 PM   #1
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Works on Computer, not on Web Site

I just updated an old site using PP11, uploaded the update with a separate FTP program. The rollovers don't work with either Firefox or IE on either of two computers. After several hours work, I downloaded the whole site to an empty folder on my computer. The rollovers work fine there; still don't work on the site. Part of my efforts to solve this included copying all the _wp_generated folder files to the main site page and deleting all the _wp_generated portions of the file path names. No change. Tried other things but when I found that the downloaded file rollovers work on the computer I gave up. Note this test folder has nothing else in it. Using XP Home, SR2. Any ideas? TIA. One other thing: I don't like that some generated image file names have caps, such as AN123.jpg. This has also caused problems tho those I can fix.
Walter K.
PS: to look at the site go to http://home.comcast.net/~knoth. The menu items on the index page should all be rollvers; their link property works fine.
 
Old 8th April 2006, 08:15 AM   #2
ArtB
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Works on Computer, not on Web Site

Walter

Your home page tells me that there is "an error page", so it could be that something can't be found.

PP11 (I take it you have got the latest version loaded) doesn't need you to play around with the_wp_generated folder so I think I'd suggest re-publishing the site, making sure all old files are deleted.

Art
 
Old 8th April 2006, 03:34 PM   #3
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Works on Computer, not on Web Site

It's strange that I haven't seen any error message. What browser are you using? I agree I shouldn't have to play around with the _wp_generated folder; I only tried it as a last resort because of the rollovers not working. It didn't help - or hurt. When I downloaded the site to a new folder on my computer I took everything including any old unrelated files that may have been on the site. As I said, the rollovers work fine with the downloaded files so it's hard to see how an extraneouus file can be messing things up. Thanks for your ideas anyway, I'll keep playing around with it and looking for an error message. Again, what browser are you using? At what stage do you get the message? Does the site load at all?
Walter K.
 
Old 8th April 2006, 07:13 PM   #4
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Another One!

Following up on my initial post in this thread I made a simple page containing only one picture, which is (or should be) a rollover. I uploaded it to a new folder on my web site - see http://home.comcast.net/~knoth/boomer. This has only a picture of a boomerang which should be a rollover. The rollover does not work on the web page but does work when viewed from a folder on my computer! I then reloaded an old version of my site, made with PP8, onto a new folder on my site and the old rollovers work fine. (The code generated by PP8 differs from that generated by PP11.) Has anyone made a rollover with PP11 (latest patch) and had it work on a web site? Any ideas what is going on here? If anyone should see the rollover on the boomer page the second image is distorted. I know that, a perfect picture wasn't the point - getting it to work was.
Walter K.
 
Old 8th April 2006, 07:37 PM   #5
Kurt Johnston
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Walter,
I'm running Maxthon and in the bottom left corner it shows a yellow triangle indicating an error. When I double click the triangle I get the attached error message.

Kurt
 
Old 8th April 2006, 09:54 PM   #6
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Kurt,
Thanks, that should be a help. I think any error has to be due to PP because it is such a simple page. Now I have something to work with; however, starting in about one hour we will have guests for a week so who knows when I can spend much time on it for awhile. If it is a PP error I am amazed no one has reported it before. I never heard of Maxthon; that error reporting seems very useful.
Walter K.
ADDED IN EDIT: I just duplicated the boomer page using WP8; the rollover works fine on the web! Now I have to compare the index files and see what the problem is, but it now definitely looks like a PP11 bug to me now. WP8 does not use a separate js file like PP11 does; maybe that it part of it?
 
Old 9th April 2006, 08:57 PM   #7
ArtB
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Walter

I think you've been playing! Try the following link, this is a single page with rollover just letting PP11 do it's stuff.

The page is published to disk and then files were uploaded to my webspace.

The pictures are just random BTW

http://arttest.mysite.wanadoo-members.co.uk/index.html

Art

 
Old 9th April 2006, 09:31 PM   #8
Mike Koewler
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Works on Computer, not on Web Site

Walter,

Check your site and make sure there is a file jsRollover.js in the root directory. I just tried with PP11 and didn't have a problem.

Mike
 
Old 11th April 2006, 03:31 PM   #9
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

ArtB: No, I wasn't playing with the boomer page, which still doesn't work on the Web but does on my computer. The FireFox Java console gives an error message "PPimgInit not defined" although the source code, which in this instance I did not modify, looks a lot like the source code foryour page, which does work. When I get a chance I'll compare them more closely. If you could email me a copy of your jsRollover.js file for that page I would appreciate it. I still don't know what's going on but I am happy to know the rollover works for someone. Thanks.
Walter K.
 
Old 11th April 2006, 04:51 PM   #10
Mike Koewler
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Walter,

It appears you do not have jsRollover.js in the right place. That file is not found on your server. On my server, it is placed in the same folder as the index.html file.

http://home.comcast.net/~knoth/boomer/jsRollover.js] http://home.comcast.net/~knoth/boomer/jsRollover.js [/url]

Mike
 
Old 11th April 2006, 05:20 PM   #11
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Mike, Kurt, & ArtB: Mystery Solved - but it wouldn't have been without your collective help - Thanks!
I used a 3d party FTP program to upload (32bit FTP) and it converts any uppercase letter to lowercase (have to see if there is an option to turn that off) and thus jsRollover.js became jsrollover.js and, though it was in the right place, it was not recognized. At the end pf my first post in this thread I said I did not like that PP was capitalizing generated image file names - that was giving me problems for the same reason. I fixed that but the lower-casing of jsRollover completely escaped me. I just fixed that and it works now. Thanks for pointing me in the right direction. I still think having PP (and probably WP) use caps is not a good idea, Unix being what it is.
Walter K.
 
Old 11th April 2006, 06:44 PM   #12
'Awful Punster'
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Walter,

&nbsp; >>> it converts any uppercase letter to lowercase (have to see if there is an option to turn that off) <<<

The 32bit FTP Manual http://www.electrasoft.com/manualf.txt refers to a 'Copy to Remote Site in lower case' checkbox.

Alfred

Click here to visit my Serif-related pages http://serif.awfulpunster.info' onMo..."";return true
 
Old 11th April 2006, 07:33 PM   #13
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

AP, Yeh, I found that; it was checked so I turned it off and I can upload in caps now. All fixed, thanks. I am deleting the boomer page - it was just a test site till the rollover problem was solved. My main page had the same problem so I have now been able to fix that also.
Walter K.

 
Old 11th April 2006, 09:23 PM   #14
ArtB
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Walter

Brilliant, another one bites the dust!! Glad your problem is sorted.

Art
 
Old 12th April 2006, 05:19 PM   #15
sydney harrod
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

But would you not generally advise excluding upper-case from all filenames intended for web-sites?

Sydney
 
Old 12th April 2006, 09:43 PM   #16
Walter K
Message imported from old Serif Forum
 
Posts: n/a
Lightbulb Re:Another One!

Sydney, yes I would but I am not an expert. If you use PP11 (and probably WP and other Serif programs) you get a lot of caps - in PP generated image names as well as in the jsRollover.js file. So the choice is either uploading them that way or editing (changing to lower case) the names as well as any reference to them in the index file. Your choice but I wish they were lower case in the first place. Any input from Serif staffers about this would be welcome.
Walter K.
 
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:39 PM.